Slow loading times for the Admin area and Storefronts
Incident Report for Uscreen
Resolved
Our team has identified the issue and promptly implemented a quick fix. All loading speeds should resume to normal.
Posted Sep 24, 2024 - 20:46 UTC
Investigating
We’re investigating a slow loading issue affecting both the Admin portal and the storefront. We’ll provide an update as our team continues its investigation.
Posted Sep 24, 2024 - 20:25 UTC
This incident affected: Admin Portal and Storefront.