Issues with upstream DNS provider -> Heroku
Incident Report for Uscreen
Resolved
This incident has been resolved.
Posted Aug 24, 2022 - 01:28 UTC
Identified
While the Heroku team is working on a global fix, our team implemented a temporary fix.
Posted Aug 24, 2022 - 00:55 UTC
Investigating
Engineers identified and are investigating an issue with an upstream DNS provider starting around 19:33 UTC Aug 23rd, leading to increased failure of insert/delete/changes to DNS.

You can see DNS_PROBE_FINISHED_NXDOMAIN errors during page loads.
Posted Aug 24, 2022 - 00:39 UTC
This incident affected: Storefront.